Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 03, 2025 - 17:00 UTC
Scheduled
Start Date and Time: Thursday, April 3, 2025 17:00 UTC End Date and Time: Thursday, April 3, 2025 18:00 UTC Affected TLDs: .cloud
The following will be unavailable during maintenance: epp.registry.cloud console.registry.cloud
The maintenance is estimated to be completed by 18:00 UTC of the same day.
During maintenance, registrar partners may be unable to manage their .cloud domains. We will update this post and send communication once maintenance is complete.
This affects the following: Domain updates Domain purchases
We plan to failover the .cloud registry backend instance on Thursday, April 3, 2025. We are transitioning all services from the active to the stand-by data center. The failover procedure will interrupt registrar services while service connections are shifted between data centers until nominal operations are confirmed. DNS and RDDS services will not be affected.
For questions regarding the maintenance, please contact the Tucows Registry Services support team at trs-support@tucows.com.
Posted Mar 19, 2025 - 20:09 UTC
This scheduled maintenance affected: .CLOUD (Production).